How to ignore Sage accounts not in CRM?

Apr 10, 2008 at 1:11 PM
Hi
I've just set up the Sage connector between Sage V14 (seems to work fine despite documentation showing up to V12 as ok)

It's now doing it's first full data transfer.
One issue is it is creating a new CRM account for any Sage records that don't have a matching account in CRM.
I don't want this. I want it to only update CRM account records that have an account ref that matches and ignore any Sage accounts that don't have a CRM accoutn record.
Is it possible to achieve this?

Thanks
Apr 10, 2008 at 4:28 PM
Edited Apr 10, 2008 at 4:29 PM
Bad form to follow up my own original post but anyway.

Been playing with the syncronisation and I have another issue.
I had already removed a whole batch of field mappings in the Sage connector to avoid Sage data overwriting CRM data.
I was left with Credit limit Credit on hold and of course accout ref.
This seems to update fine.
I then looked at the other fields avaialble in Sage and decided to bring some of those across as well.
I created new attributes for CRM account and then made new field mappings.
However when it sycs the new mappings don't seem to transfer the data.
The cross mappings show data (SEE BELOW)

But the accoutn records show as empty? If I manually enter data in a field in CRM and then run the sync it doesn't even wipe the data just leaves the old data there.
The only difference I can see is all my new attributes start with New_ but can't see how that is the issue.

<account xmlns='http://schemas.microsoft.com/crm/2006/WebServices'><accountid xmlns='http://schemas.microsoft.com/crm/2006/WebServices'>d8eaf9fd-ec44-dc11-8cd9-0017a43b7acb</accountid><accountnumber xmlns='http://schemas.microsoft.com/crm/2006/WebServices'>TESTFILMS</accountnumber><creditlimit xmlns='http://schemas.microsoft.com/crm/2006/WebServices'>2000</creditlimit><creditonhold xmlns='http://schemas.microsoft.com/crm/2006/WebServices'>0</creditonhold><revenue xmlns='http://schemas.microsoft.com/crm/2006/WebServices'>55</revenue><telephone2 xmlns='http://schemas.microsoft.com/crm/2006/WebServices'>TEST Films</telephone2><Newpaymentterms xmlns='http://schemas.microsoft.com/crm/2006/WebServices'></Newpaymentterms><NewLastInvDate xmlns='http://schemas.microsoft.com/crm/2006/WebServices'>13/03/2008 00:00:00</NewLastInvDate><NewBalance xmlns='http://schemas.microsoft.com/crm/2006/WebServices'>0</NewBalance><NewTurnoverMTD xmlns='http://schemas.microsoft.com/crm/2006/WebServices'>55</NewTurnoverMTD><NewTurnoverYTD xmlns='http://schemas.microsoft.com/crm/2006/WebServices'>55</NewTurnoverYTD><NewPriorYear xmlns='http://schemas.microsoft.com/crm/2006/WebServices'>956</NewPriorYear><NewDateAccountOpened xmlns='http://schemas.microsoft.com/crm/2006/WebServices'>27/09/2000 00:00:00</NewDateAccountOpened><NewTermsAgreed xmlns='http://schemas.microsoft.com/crm/2006/WebServices'>1</NewTermsAgreed></account>